We're back online with the UK eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Apr 27, 2026 - 02:59 AEST

Investigating

We are experiencing some intermittent technical issues with the following eGift cards:

* Sainsbury's
* Sainsbury's Groceries
* Argos

We are working to fix this.
Please check back soon!

MAR-2105
Posted Apr 26, 2026 - 22:25 AEST
This incident affected: Stock Availability (UK).