We're experiencing technical issues with some UK eGift cards

Incident Report for Prezzee

Update

We’re experiencing some technical issues with the following eGift cards:

Costa Coffee
The Entertainer
Hotels.com




We're working to fix this.
Please check back soon!

MAR-2404
Posted Sep 02, 2026 - 17:46 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

Costa Coffee
The Entertainer
ASOS
Hotels.com




We are working to fix this.
Please check back soon!

MAR-2404
Posted Sep 02, 2026 - 17:35 AEST
This incident affects: Stock Availability (UK).