We are back online with Google Play $50 in CA

Incident Report for Prezzee

Resolved

We have resolved our technical issues with Google Play $50 in CA. The cards are now available for purchase.
Posted Mar 11, 2026 - 09:41 AEDT

Identified

We are currently having some technical issues with Google Play $50 eGift cards in CA. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2015
Posted Mar 10, 2026 - 19:41 AEDT
This incident affected: Stock Availability (CA).