Telstra AU $35.00 now back in stock
Incident Report for Prezzee
Resolved
We have successfully restocked Telstra AU $35.00 and these cards are now available for purchase.
Posted Sep 14, 2024 - 10:35 AEST
Identified
We’re experiencing a stock issue with Telstra AUD $35.00. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-1127
Posted Sep 13, 2024 - 16:37 AEST
This incident affected: Stock Availability (AU).