No Lowes $20 stock currently available in AU
Incident Report for Prezzee
Resolved
We have successfully restocked Lowes AU $20 and these cards are now available for purchase.
Posted Sep 06, 2024 - 15:33 AEST
Identified
We’re experiencing a stock issue with Lowes AU $20. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-1040
Posted Jul 19, 2024 - 18:47 AEST