Brooklinen, US $100 now back in stock
Incident Report for Prezzee
Resolved
We have successfully restocked Brooklinen, US $100 and these cards are now available for purchase.
Posted Sep 06, 2024 - 03:50 AEST
Identified
We’re experiencing a stock issue with Brooklinen US $100. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-882
Posted May 04, 2024 - 17:11 AEST
This incident affected: United States (Prezzee Business API) and Stock Availability (US).