We are back online with B&Q £15, £20, £30, £75, £150 £250 in UK

Incident Report for Prezzee

Resolved

We have resolved our technical issues with B&Q £15, £20, £30, £75, £150 £250 in UK. The cards are now available for purchase.
Posted Jun 28, 2025 - 17:28 AEST

Update

We are currently having some technical issues with B&Q £15, £20, £30, £75, £150 £250 eGift cards.

Please check back soon.

MAR-1585
Posted Jun 20, 2025 - 20:19 AEST

Identified

We are currently having some technical issues with B&Q £15,£20,£30,£75,£150 eGift cards in UK. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1585
Posted Jun 20, 2025 - 20:15 AEST
This incident affected: Stock Availability (UK).