Eva AU $150 has been discontinued

Incident Report for Prezzee

Resolved

This is to notify you that Eva $150 has been discontinued and is no longer available for sale in AU.

MAR-2360
Posted Sep 17, 2026 - 14:43 AEST

Update

We’re experiencing a stock issue with Eva $150. We’re working hard to get more stock ASAP.

Please check back soon.
MAR-2360
Posted Aug 13, 2026 - 16:33 AEST

Update

We’re experiencing a stock issue with Eva $150, $250, and $500. We’re working hard to get more stock ASAP.

Please check back soon.
MAR-2360
Posted Aug 13, 2026 - 11:24 AEST

Identified

We are experiencing a stock issue with Eva $150 and $500. We are working hard to get more stock ASAP.

Please check back soon.
MAR-2360
Posted Aug 12, 2026 - 18:19 AEST
This incident affected: Stock Availability (AU).