No Poshmark stock currently available in US
Incident Report for Prezzee
Update
We are continuing to work on a fix for this issue.
Posted Jul 10, 2024 - 03:54 AEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 09, 2024 - 15:26 AEST
Identified
We’re experiencing a stock issue with Poshmark US $25, $50, $100 and $500. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-994
Posted Jun 26, 2024 - 06:53 AEST