S.T. Dupont AU - Temporarily Disabled

Incident Report for Prezzee

Resolved

S.T. Dupont has notified us that they have temporarily disabled their gift card until further notice. We apologise for any inconvenience this might cause. We will let you know when we receive further updates.

MAR-1678
Posted Dec 10, 2025 - 09:14 AEDT

Update

We’re experiencing a stock issue with S.T. Dupont $100, $250, $500 and $2000. We’re working hard to get more stock ASAP.

Please check back soon.
MAR-1678
Posted Oct 06, 2025 - 00:18 AEDT

Identified

We are experiencing a stock issue with S.T. Dupont $100,$250,$500 . We are working hard to get more stock ASAP.

Please check back soon.
MAR-1678
Posted Sep 03, 2025 - 15:27 AEST
This incident affected: Stock Availability (AU).