Adore Beauty, NZ $25 now back in stock

Incident Report for Prezzee

Resolved

We have successfully restocked Adore Beauty, NZ $25 and these cards are now available for purchase.
Posted Jan 06, 2026 - 09:17 AEDT

Identified

We are experiencing a stock issue with Adore Beauty $25. We are working hard to get more stock ASAP.

Please check back soon.
MAR-1896
Posted Dec 20, 2025 - 05:13 AEDT
This incident affected: Stock Availability (AU).