We're back online with these brands in UK
Incident Report for Prezzee
Resolved
We have resolved our technical issues and the cards are now available for purchase.

Just Eat
Xbox Currency
Google Play

ref: MAR-1118
Posted Sep 09, 2024 - 02:02 AEST
Investigating
We’re experiencing some technical issues with the following eGift cards:

Just Eat
Xbox Currency
Google Play

We're working to fix this.
Please check back soon!

ref: MAR-1118
Posted Sep 08, 2024 - 09:34 AEST
This incident affected: Stock Availability (UK).