We're experiencing technical issues with Main Event $30.00 in US
Incident Report for Prezzee
Resolved
We have resolved our technical issues and this card is now available for purchase.

ref: MAR-690
Posted Sep 10, 2024 - 17:40 AEST
Investigating
We’re having some technical issues at the moment with Main Event US $30.00 eGift cards and working to fix this. Please check back soon!

ref: MAR-690
Posted Jan 11, 2024 - 16:43 AEDT