We are experiencing technical issues with Shutterfly in US

Incident Report for Prezzee

Update

We are continuing to work on a fix for this issue.
Posted Apr 29, 2025 - 16:27 AEST

Identified

We are currently having some technical issues with Shutterfly eGift cards in US. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1504
Posted Apr 29, 2025 - 15:54 AEST
This incident affects: Stock Availability (US).