We are experiencing technical issues with National Garden Voucher £30, £50, £100, £150, £200, and £250 in UK

Incident Report for Prezzee

Update

We are currently having some technical issues with National Garden Voucher £30, £50, £100, £150, £200, and £250 eGift cards.

Please check back soon.

MAR-2081
Posted Apr 19, 2026 - 08:10 AEST

Update

We are currently having some technical issues with National Garden Voucher £50, £100, £150, £200, and £250 eGift cards.

Please check back soon.

MAR-2081
Posted Apr 19, 2026 - 04:56 AEST

Update

We are currently having some technical issues with National Garden Voucher £200, and £250 eGift cards.

Please check back soon.

MAR-2081
Posted Apr 19, 2026 - 02:35 AEST

Identified

We are currently having some technical issues with National Garden Voucher £250 eGift cards in UK. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2081
Posted Apr 18, 2026 - 23:53 AEST
This incident affects: Stock Availability (UK).