No Laithwaite's £20.00, £50.00 and £100.00 stock currently available in UK
Incident Report for Prezzee
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2024 - 07:04 AEST
Update
We are continuing to work on a fix for this issue.
Posted Jun 24, 2024 - 21:57 AEST
Identified
We’re experiencing a stock issue with Laithwaite's UK £100.00. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-842
Posted Apr 05, 2024 - 02:56 AEDT