We're back online with the AU eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Aug 13, 2026 - 03:24 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

Apple
PlayStation Store
Xbox
Razer Gold
Google Play
DoorDash
JB Hi-Fi

We are working to fix this.
Please check back soon!

MAR-2363
Posted Aug 12, 2026 - 23:44 AEST
This incident affected: Stock Availability (AU).