We're back online with the US eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Jul 31, 2026 - 22:40 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Sheetz
* Phillips 66 - Conoco - 76
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox
* Nintendo eShop
* DoorDash
* Wawa
* Albertsons
* TopGolf
* Best Buy
* Foot Locker
* Instacart
* Grubhub
* Lowe's
* Crutchfield®
* GAP
* Amc Theatres

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 21:22 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Sheetz
* Phillips 66 - Conoco - 76
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox
* Nintendo eShop
* DoorDash
* Wawa
* Albertsons
* TopGolf
* Best Buy
* Foot Locker
* Instacart
* Grubhub
* Lowe's
* Crutchfield®

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 21:17 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Sheetz
* Phillips 66 - Conoco - 76
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox
* Nintendo eShop
* DoorDash
* Wawa
* Albertsons
* TopGolf
* Best Buy
* Foot Locker
* Instacart
* Grubhub

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 21:03 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Sheetz
* Phillips 66 - Conoco - 76
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox
* Nintendo eShop
* DoorDash
* Wawa
* Albertsons
* TopGolf
* Best Buy
* Foot Locker

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 21:00 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Sheetz
* Phillips 66 - Conoco - 76
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox
* Nintendo eShop
* DoorDash
* Wawa
* Albertsons
* TopGolf
* Best Buy

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 20:54 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Sheetz
* Phillips 66 - Conoco - 76
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox
* Nintendo eShop
* DoorDash
* Wawa
* Albertsons
* TopGolf

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 20:53 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Sheetz
* Phillips 66 - Conoco - 76
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox
* Nintendo eShop

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 20:31 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Lyft
* Google Play
* Starbucks
* Sheetz
* Phillips 66 - Conoco - 76
* Carnival Cruise Lines
* Sam’s Club
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox
* Nintendo eShop

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 20:21 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Lyft
* Google Play
* Starbucks
* Sheetz
* Phillips 66 - Conoco - 76
* Carnival Cruise Lines
* Sam’s Club
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors
* Xbox

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 20:13 AEST

Update

We’re experiencing some technical issues with the following eGift cards:



* Lyft
* Google Play
* Starbucks
* Sheetz
* Phillips 66 - Conoco - 76
* Carnival Cruise Lines
* Sam’s Club
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 20:03 AEST

Update

We’re experiencing some technical issues with the following eGift cards:

* Walmart
* Lyft
* Google Play
* Starbucks
* Sheetz
* Phillips 66 - Conoco - 76
* Carnival Cruise Lines
* Sam’s Club
* Dutch Bros Coffee
* TJX Multi-Brand
* Academy Sports + Outdoors

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 19:59 AEST

Update

We’re experiencing some technical issues with the following eGift cards:

* Walmart
* Lyft
* Google Play
* Starbucks
* Sheetz
* Phillips 66 - Conoco - 76
* Carnival Cruise Lines
* Sam’s Club
* Dutch Bros Coffee
* TJX Multi-Brand

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 19:50 AEST

Update

We’re experiencing some technical issues with the following eGift cards:

* Walmart
* Lyft
* Google Play
* Starbucks
* Sheetz
* Phillips 66 - Conoco - 76
* Carnival Cruise Lines
* Sam’s Club
* Dutch Bros Coffee

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 19:49 AEST

Update

We’re experiencing some technical issues with the following eGift cards:

* Walmart
* Lyft
* Google Play
* Starbucks
* Sheetz
* Phillips 66 - Conoco - 76
* Carnival Cruise Lines
* Sam’s Club

We're working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 19:43 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

* Walmart
* Lyft
* Google Play
* Starbucks
* Sheetz
* Phillips 66 - Conoco - 76
* Carnival Cruise Lines

We are working to fix this.
Please check back soon!

MAR-2343
Posted Jul 31, 2026 - 19:29 AEST
This incident affected: Stock Availability (US).