We're back online with the US eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Apr 03, 2026 - 01:41 AEDT

Investigating

We are experiencing some technical issues with the following eGift cards:

Uber

Airbnb

Instacart

Uber Eats

eBay

DoorDash

Etsy

Xbox Game Pass Ultimate

We are working to fix this.
Please check back soon!

MAR-2045
Posted Apr 02, 2026 - 21:03 AEDT
This incident affected: Stock Availability (US).