We're experiencing technical issues with Loch Fyne £100 in UK
Incident Report for Prezzee
Resolved
We regret to inform you that Loch Fyne has been discontinued and is no longer available for sale in the UK.

We sincerely apologize for any inconvenience this may cause.
Posted Sep 12, 2024 - 16:57 AEST
Investigating
We’re having some technical issues at the moment with Loch Fyne UK £100 eGift cards and working to fix this. Please check back soon!

ref: MAR-806
Posted Mar 18, 2024 - 05:25 AEDT