Harmon Face Values US 30$ has been discontinued

Incident Report for Prezzee

Resolved

This is to notify you that Harmon Face Values 30$ has been discontinued and is no longer available for sale in US.

MAR-1591
Posted Oct 29, 2025 - 01:27 AEDT

Identified

We are experiencing a stock issue with Harmon Face Values 30$. We are working hard to get more stock ASAP.

Please check back soon.
MAR-1591
Posted Jul 01, 2025 - 03:45 AEST
This incident affected: Stock Availability (US).