We are experiencing technical issues with Prouds the Jewellers in AU

Incident Report for Prezzee

Update

We are currently having some technical issues with Prouds the Jewellers eGift cards in AU. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1756
Posted Oct 20, 2025 - 13:37 AEDT

Identified

We are currently having some technical issues with Prouds the Jewellers $200 eGift cards in AU. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1756
Posted Oct 20, 2025 - 10:55 AEDT
This incident affects: Stock Availability (AU).