Farmers, NZ $20 now back in stock

Incident Report for Prezzee

Resolved

We have successfully restocked Farmers, NZ $20 and these cards are now available for purchase.
Posted Jul 01, 2025 - 10:57 AEST

Identified

We are experiencing a stock issue with Farmers $20 . We are working hard to get more stock ASAP.

Please check back soon.
MAR-1596
Posted Jul 01, 2025 - 08:17 AEST
This incident affected: Stock Availability (NZ).